Joomla! 3.3 compatibility

Joomla! 3.3 has been released days ago (1st of May 2014) and we are now happy to announce all our extensions were tested succesfully with this Joomla! release and fully compatible. Actually this testing was already done with the Beta version of 3.3 but last couple of days we made sure nothing dramatically changed.

Drop LTS and STS

Before, Joomla! kept the Joomla! 2.5 version to be the Long Term Support (LTS) version and the entire Joomla! 3 branch was filled with Short Term Support (STS) versions until Joomla! 3.5 would replace 2.5 as LTS. This has now changed. There is no more LTS and STS, and the next Joomla! 3.4 release is simply marked as the stable version.

For our Yireo extensions we want to make this meaningful as well: We will shift the main development from Joomla! 2.5 to Joomla! 3.x. As of yet, we have been developing most of our stuff under Joomla! 2.5, and then copying changes to Joomla! 3. This means we were still struggling a lot with new Joomla! 3 features that do not exist in Joomla! 2 natively (Twitter Bootstrap, new extension manager features, new plugin events). With our shift to Joomla! 3 this is going to change. While all our extensions have been working fine with Joomla! 3 for ages already, we will now also be more innovative by implementing new Joomla! 3 only features - urging users to upgrade to Joomla! 3 as well. Following from this, Joomla! 2.5 will be phased out slowly.

All compatible?

No, actually I lied: One extension is still not fully compatible with Joomla! 3 at all, and that is Vm2Mage - a conversion tool from VirtueMart to Magento. The main purpose of this extension is to migrate from old Joomla! 1.5 sites to Magento, and so far there has been even little demand for a Joomla! 2.5 version. Vm2Mage is already fully compatible with Joomla! 2.5 though and we are slowly working on Joomla! 3 compatibility. The current VirtueMart version is not even compatible with Joomla! 3, only VM version 2.4 will mark Joomla! 3 compatibility. So it will take some time before there is actually a need to migrate away from Joomla! 3 plus VirtueMart :)