Upgrading Vm2Mage

Vm2Mage is an ongoing project. As more VirtueMart sites are migrated to Magento, more work will be put into new features or bugfixes of the Vm2Mage extensions. If you encounter a bug, first upgrade to the latest available version. This tutorial shows you how to do that.

Upgrading Vm2Mage in Joomla!

To upgrade the Vm2Mage component in Joomla, download the latest package from our site and install it in the Joomla! Administrator.

Upgrading Vm2Mage in Magento

Browse to the Magento Downloader application of your site. Hit the button Check for Updates. If there is a new version of Vm2Mage available, this should be listed. For the Yireo_Vm2Mage extension select the action Upgrade and hit the button Commit Changes.

Make sure your file-permissions are correct. It's easiest to copy all the file-permissions from the main Magento index.php file.

If an update is not listed by the Magento Downloader application, but the Joomla! component has a new version anyway, it might be that the Magento Downloader cache is outdated. We try to keep the version of the Joomla! component and the Magento extensions in sync at all times. To force an upgrade, you can just reinstall the extensions. To reinstall the extension, you can use the following extension keys.

magento-community/Yireo_Vm2Mage
magento-community/Yireo_VmOrder

Make sure you have both extensions installed, when running the Vm2Mage component from Joomla!. After the Vm2Mage migration has finished, you can safely remove the Yireo_Vm2Mage extension. Keep the Yireo_VmOrder extension installed if you want to make the old VirtueMart orders available to your customers. If you don't have any orders, its safe to remove Yireo_VmOrder as well.