EOL of Joomla! 1.5 extensions

ripAs of today, various of our Joomla! components no longer have support for Joomla! 1.5 - the previous version of Joomla! that became officially obsolete in April 2012. Here's a listing of our changed support:

Joomla! components

Joomla! 1.5 support has been withdrawn now for the following components:

  • SimpleLists
  • BingTranslate
  • GoogleTranslate
  • Dynamic404
  • TweetScheduler
  • PayPal Access

For all these components, the Joomla! 1.5 versions are still available in their download-folders. But newer versions of these components will not be developed for Joomla! 1.5. With these versions, the PHP-code will also be cleant up: A custom form-API will be replaced with the generic JForm-library. The MVC-structure will be cleant up. And of course, all chungs of old Joomla! 1.5 code will be removed.

Also, support (through our forum or onsite-support) for Joomla! 1.5 will only be available for paying customers.

Joomla! plugins

Various smaller plugins we offer will support Joomla! 1.5 for some time to come: The codebase of those plugins is fairly simple and it takes little time to support Joomla! 1.5 as well. Support for 1.5 will eventually be withdrawn somewhere in 2013:

  • FancyBox
  • SSLRedirect
  • ScriptMerge
  • SEFTest
  • HTTP Authentication

MageBridge

We will continue to offer support for MageBridge under Joomla! 1.5 until the release of MageBridge 2.0 next year. That major rewrite of MageBridge will not support Joomla! 1.5 and will only work under Joomla! 2.5 and Joomla! 3.x. However, we will also focus on building more MageBridge-based solutions, and those solutions will only be built for Joomla! 2.5 or later. An example of this is our new MageBridge Lightbox plugin.