About PHP versions

We frequently get questions on why our extensions don't work under outdated PHP versions. Because of this, we have summed up our thoughts. If you are using an outdated PHP version, this guide explains everything we could tell you about that.

Why should you upgrade?

We build PHP extensions for PHP applications. This means that, whenever PHP evolves, our extensions also needs to evolve. Likewise, if PHP is putting a certain PHP version out of production, we can't support it as well. In short: PHP versions get outdated. And upgrading is needed for various reasons:

  • Security: PHP contains bugs and some bugs could involve hackers taking over your site. If those bugs are fixed, they are fixed by releasing new versions. So upgrading is required to fix security holes.

  • Performance: PHP is made faster with every release. The upgrade from PHP 5 to PHP 7 is dramatic, because it doubles performance in some cases. Not upgrading means less conversion, so less money, so you're stealing from yourself.

  • New features: Every software package evolves, every developer evolves. To make PHP applications better, it is also needed that PHP itself changes. This also means that some new features will only be made available in PHP applications, if PHP itself is upgraded on the hosting level. This is why the minimum requirements of Joomla and Magento are raised every time again. By keeping your PHP version up-to-date, upgrading those applications becomes easier as well.

About specific PHP versions

Below, you can read our stand on the various PHP versions. To see which version is supported until which time, see the official PHP page on Supported Versions. Bookmark that page.

PHP 5.3

PHP 5.3 is old, slow, buggy and it should not be used. If you're still using this, you should think about your life and why you are running a site. Worse, if you are running PHP 5.3.3 specifically, you should contact a developer to upgrade things ASAP. You should not be using PHP 5.3. No discussion.

PHP 5.4

With PHP 5.4, performance was increased. Also, various developer-oriented features were introduced like traits. We have raised our minimum PHP version to 5.4 a long time ago. However, at this moment, you should not be using this version anymore: Official support has stopped in 2014. You are at risk when running this version.

PHP 5.5

To us, this version offered only a little benefit from 5.4 and it is better to have been using 5.6 for a long time. Again, this version is no longer supported since July 2016.

PHP 5.6

This version is supported but not current. We have PHP 7 now.

PHP 7.0

If you are running PHP 5.6, you could double performance by upgrading to PHP 7. This sometimes means that the software (core application, extensions) also needs to be upgraded. Currently, all Magento and Joomla sites that we know of can be upgraded to PHP 7 with simple steps. If you are wary about upgrading, setup a testing site and try things there. Putting effort in upgrading to PHP 7 is worth a lot.

PHP 7.1

Upgrading from 7.0 to 7.1 is recommended. Many bugs are fixed. Just upgrade.